CVE-2022-41325

NameCVE-2022-41325
DescriptionAn integer overflow in the VNC module in VideoLAN VLC Media Player through 3.0.17.4 allows attackers, by tricking a user into opening a crafted playlist or connecting to a rogue VNC server, to crash VLC or execute code under some conditions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3216-1, DSA-5297-1, ELA-749-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)jessie, jessie (lts)2.2.7-1~deb8u1vulnerable
stretch (security)3.0.12-0+deb9u1vulnerable
stretch (lts), stretch3.0.20-0+deb9u1fixed
buster3.0.17.4-0+deb10u1vulnerable
buster (security)3.0.20-0+deb10u1fixed
bullseye (security), bullseye3.0.20-0+deb11u1fixed
bookworm (security), bookworm3.0.20-0+deb12u1fixed
sid, trixie3.0.20-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsourcejessie(unfixed)end-of-life
vlcsourcestretch3.0.17.4-0+deb9u2ELA-749-1
vlcsourcebuster3.0.17.4-0+deb10u2DLA-3216-1
vlcsourcebullseye3.0.18-0+deb11u1DSA-5297-1
vlcsource(unstable)3.0.18-1

Notes

https://www.videolan.org/security/sb-vlc3018.html
https://code.videolan.org/videolan/vlc/-/issues/27335

Search for package or bug name: Reporting problems