CVE-2022-41859

NameCVE-2022-41859
DescriptionIn freeradius, the EAP-PWD function compute_password_element() leaks information about the password which allows an attacker to substantially reduce the size of an offline dictionary attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3342-1, ELA-809-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeradius (PTS)jessie, jessie (lts)2.2.5+dfsg-0.2+deb8u1fixed
stretch (security)3.0.12+dfsg-5+deb9u1vulnerable
stretch (lts), stretch3.0.17+dfsg-1.1+deb9u1fixed
buster3.0.17+dfsg-1.1+deb10u1vulnerable
buster (security)3.0.17+dfsg-1.1+deb10u2fixed
bullseye3.0.21+dfsg-2.2+deb11u1vulnerable
bookworm3.2.1+dfsg-4+deb12u1fixed
trixie3.2.5+dfsg-2fixed
sid3.2.5+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeradiussourcejessie(not affected)
freeradiussourcestretch3.0.17+dfsg-1.1+deb9u1ELA-809-1
freeradiussourcebuster3.0.17+dfsg-1.1+deb10u2DLA-3342-1
freeradiussource(unstable)3.2.0+dfsg-1

Notes

[bullseye] - freeradius <no-dsa> (Minor issue)
https://github.com/FreeRADIUS/freeradius-server/commit/9e5e8f2f912ad2da8ac6e176ac3a606333469937 (release_3_0_26)
[jessie] - freeradius <not-affected> (The EAP-PWD modules was introduced in later versions)

Search for package or bug name: Reporting problems