CVE-2022-4254

NameCVE-2022-4254
Descriptionsssd: libsss_certmap fails to sanitise certificate data used in LDAP filters
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3436-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sssd (PTS)jessie, jessie (lts)1.11.7-3+deb8u2fixed
stretch (security), stretch (lts), stretch1.15.0-3+deb9u2fixed
buster1.16.3-3.2vulnerable
buster (security)1.16.3-3.2+deb10u2fixed
bullseye2.4.1-2fixed
bookworm2.8.2-4fixed
sid2.9.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sssdsourcejessie(not affected)
sssdsourcestretch(not affected)
sssdsourcebuster1.16.3-3.2+deb10u1DLA-3436-1
sssdsource(unstable)2.3.1-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=2149894
https://github.com/SSSD/sssd/issues/5135
https://github.com/SSSD/sssd/commit/a2b9a84460429181f2a4fa7e2bb5ab49fd561274
https://github.com/SSSD/sssd/commit/918fb32af6a271230bf87db47f78768edb9ca86c (sssd-1-16)
[stretch] - sssd <not-affected> (The vulnerable code was introduced later)
[jessie] - sssd <not-affected> (The vulnerable code was introduced later)

Search for package or bug name: Reporting problems