CVE-2023-23454

NameCVE-2023-23454
Descriptioncbq_classify in net/sched/sch_cbq.c in the Linux kernel through 6.1.4 allows attackers to cause a denial of service (slab-out-of-bounds read) because of type confusion (non-negative numbers can sometimes indicate a TC_ACT_SHOT condition rather than valid classification results).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3349-1, DLA-3403-1, DSA-5324-1, ELA-810-1, ELA-847-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch (security)4.9.320-2vulnerable
stretch (lts), stretch4.9.320-3vulnerable
buster4.19.249-2vulnerable
buster (security)4.19.289-2fixed
bullseye5.10.178-3fixed
bullseye (security)5.10.191-1fixed
bookworm6.1.38-1fixed
bookworm (security)6.1.52-1fixed
sid, trixie6.5.3-1fixed
linux-4.19 (PTS)jessie, jessie (lts)4.19.289-2~deb8u1fixed
stretch (security)4.19.232-1~deb9u1vulnerable
stretch (lts), stretch4.19.289-2~deb9u1fixed
linux-5.10 (PTS)stretch (lts), stretch5.10.179-5~deb9u1fixed
buster (security)5.10.179-5~deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch(unfixed)end-of-life
linuxsourcebuster4.19.282-1DLA-3403-1
linuxsourcebullseye5.10.162-1DSA-5324-1
linuxsource(unstable)6.1.7-1
linux-4.19sourcejessie4.19.282-1~deb8u1ELA-847-1
linux-4.19sourcestretch4.19.282-1~deb9u1ELA-847-1
linux-5.10sourcestretch5.10.162-1~deb9u1ELA-810-1
linux-5.10sourcebuster5.10.162-1~deb10u1DLA-3349-1

Notes

https://git.kernel.org/linus/caa4b35b4317d5147b3ab0fbdc9c075c7d2e9c12

Search for package or bug name: Reporting problems