CVE-2023-24757

NameCVE-2023-24757
Descriptionlibde265 v1.0.10 was discovered to contain a NULL pointer dereference in the put_unweighted_pred_16_fallback function at fallback-motion.cc. This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted input file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3352-1, DSA-5346-1, ELA-811-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libde265 (PTS)jessie0.9-1vulnerable
stretch (lts), stretch1.0.11-0+deb9u6fixed
buster1.0.3-1vulnerable
buster (security)1.0.11-0+deb10u6fixed
bullseye1.0.11-0+deb11u3fixed
bullseye (security)1.0.11-0+deb11u1fixed
bookworm1.0.11-1+deb12u2fixed
sid, trixie1.0.15-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libde265sourcejessie(unfixed)end-of-life
libde265sourcestretch1.0.11-0+deb9u3ELA-811-1
libde265sourcebuster1.0.11-0+deb10u4DLA-3352-1
libde265sourcebullseye1.0.11-0+deb11u1DSA-5346-1
libde265source(unstable)1.0.11-1

Notes

https://github.com/strukturag/libde265/issues/385
https://github.com/strukturag/libde265/commit/48eb7dafe204b825b4a62948ed171a0cd3f1bda2 (v1.0.11)

Search for package or bug name: Reporting problems