CVE-2023-27539

NameCVE-2023-27539
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3392-1, DSA-5530-1, ELA-936-1
Debian Bugs1033264

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ruby-rack (PTS)jessie, jessie (lts)1.5.2-3+deb8u4vulnerable
stretch (security)1.6.4-4+deb9u2vulnerable
stretch (lts), stretch1.6.4-4+deb9u6fixed
buster2.0.6-3vulnerable
buster (security)2.0.6-3+deb10u4fixed
bullseye (security), bullseye2.1.4-3+deb11u1fixed
bookworm2.2.6.4-1fixed
sid, trixie2.2.7-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ruby-racksourcejessie(unfixed)end-of-life
ruby-racksourcestretch1.6.4-4+deb9u5ELA-936-1
ruby-racksourcebuster2.0.6-3+deb10u3DLA-3392-1
ruby-racksourcebullseye2.1.4-3+deb11u1DSA-5530-1
ruby-racksource(unstable)2.2.6.4-11033264

Notes

https://github.com/rack/rack/commit/231ef369ad0b542575fb36c74fcfcfabcf6c530c (v3.0.6.1)
https://github.com/rack/rack/commit/ee7919ea04303717858be1c3f16b406adc6d8cff (v2.2.6.4)
https://discuss.rubyonrails.org/t/cve-2023-27539-possible-denial-of-service-vulnerability-in-racks-header-parsing/82466

Search for package or bug name: Reporting problems