CVE-2023-35823

NameCVE-2023-35823
DescriptionAn issue was discovered in the Linux kernel before 6.3.2. A use-after-free was found in saa7134_finidev in drivers/media/pci/saa7134/saa7134-core.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3508-1, DLA-3623-1, ELA-907-1, ELA-991-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch (security)4.9.320-2vulnerable
stretch (lts), stretch4.9.320-3vulnerable
buster4.19.249-2vulnerable
buster (security)4.19.304-1fixed
bullseye5.10.209-2fixed
bullseye (security)5.10.205-2fixed
bookworm6.1.76-1fixed
bookworm (security)6.1.85-1fixed
trixie6.6.15-2fixed
sid6.7.9-2fixed
linux-4.19 (PTS)jessie, jessie (lts)4.19.304-1~deb8u1fixed
stretch (security)4.19.232-1~deb9u1vulnerable
stretch (lts), stretch4.19.304-1~deb9u1fixed
linux-5.10 (PTS)jessie, jessie (lts)5.10.209-2~deb8u1fixed
stretch (lts), stretch5.10.209-2~deb9u1fixed
buster (security)5.10.209-2~deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch(unfixed)end-of-life
linuxsourcebuster4.19.289-1DLA-3508-1
linuxsourcebullseye5.10.191-1
linuxsourcebookworm6.1.37-1
linuxsource(unstable)6.3.7-1unimportant
linux-4.19sourcejessie4.19.289-1~deb8u1ELA-907-1
linux-4.19sourcestretch4.19.289-1~deb9u1ELA-907-1
linux-5.10sourcejessie5.10.197-1~deb8u1ELA-991-1
linux-5.10sourcestretch5.10.197-1~deb9u1ELA-991-1
linux-5.10sourcebuster5.10.197-1~deb10u1DLA-3623-1

Notes

https://git.kernel.org/linus/30cf57da176cca80f11df0d9b7f71581fe601389 (6.4-rc1)
Only "exploitable" by removing the module which needs root privileges

Search for package or bug name: Reporting problems