CVE-2023-43114

NameCVE-2023-43114
DescriptionAn issue was discovered in Qt before 5.15.16, 6.x before 6.2.10, and 6.3.x through 6.5.x before 6.5.3 on Windows. When using the GDI font engine, if a corrupted font is loaded via QFontDatabase::addApplicationFont{FromData], then it can cause the application to crash because of missing length checks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qt4-x11 (PTS)jessie, jessie (lts)4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u5fixed
stretch (security)4:4.8.7+dfsg-11+deb9u3fixed
stretch (lts), stretch4:4.8.7+dfsg-11+deb9u4fixed
buster (security), buster, buster (lts)4:4.8.7+dfsg-18+deb10u2fixed
qt6-base (PTS)bookworm6.4.2+dfsg-10fixed
trixie, sid6.6.2+dfsg-10fixed
qtbase-opensource-src (PTS)jessie, jessie (lts)5.3.2+dfsg-4+deb8u6fixed
stretch (security)5.7.1+dfsg-3+deb9u3fixed
stretch (lts), stretch5.7.1+dfsg-3+deb9u4fixed
buster (security), buster, buster (lts)5.11.3+dfsg1-1+deb10u6fixed
bullseye5.15.2+dfsg-9+deb11u1fixed
bookworm5.15.8+dfsg-11+deb12u2fixed
trixie, sid5.15.13+dfsg-3fixed
qtbase-opensource-src-gles (PTS)bullseye5.15.2+dfsg-4fixed
bookworm5.15.8+dfsg-3fixed
trixie, sid5.15.13+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qt4-x11source(unstable)(not affected)
qt6-basesource(unstable)(not affected)
qtbase-opensource-srcsource(unstable)(not affected)
qtbase-opensource-src-glessource(unstable)(not affected)

Notes

- qt6-base <not-affected> (Windows-specific)
- qtbase-opensource-src-gles <not-affected> (Windows-specific)
- qtbase-opensource-src <not-affected> (Windows-specific)
- qt4-x11 <not-affected> (Windows-specific)

Search for package or bug name: Reporting problems