CVE-2023-46847

NameCVE-2023-46847
DescriptionSquid is vulnerable to a Denial of Service, where a remote attacker can perform buffer overflow attack by writing up to 2 MB of arbitrary data to heap memory when Squid is configured to accept HTTP Digest Authentication.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3709-1, ELA-1037-1
Debian Bugs1055250

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster4.6-1+deb10u7vulnerable
buster (security)4.6-1+deb10u10fixed
bullseye (security), bullseye4.13-10+deb11u2vulnerable
bookworm5.7-2vulnerable
sid, trixie6.6-1fixed
squid3 (PTS)jessie, jessie (lts)3.5.23-5+deb8u7fixed
stretch (security)3.5.23-5+deb9u7vulnerable
stretch (lts), stretch3.5.23-5+deb9u10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsourcebuster4.6-1+deb10u9DLA-3709-1
squidsource(unstable)6.5-11055250
squid3sourcejessie3.5.23-5+deb8u7ELA-1037-1
squid3sourcestretch3.5.23-5+deb9u10ELA-1037-1
squid3source(unstable)(unfixed)

Notes

https://github.com/squid-cache/squid/security/advisories/GHSA-phqj-m8gv-cq4g
https://github.com/squid-cache/squid/commit/052cf082b0faaef4eaaa4e94119d7a1437aac4a3
https://megamansec.github.io/Squid-Security-Audit/digest-overflow.html

Search for package or bug name: Reporting problems