CVE-2023-46848

NameCVE-2023-46848
DescriptionSquid is vulnerable to Denial of Service, where a remote attacker can perform DoS by sending ftp:// URLs in HTTP Request messages or constructing ftp:// URLs from FTP Native input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1055251

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster4.6-1+deb10u7fixed
buster (security)4.6-1+deb10u10fixed
bullseye (security), bullseye4.13-10+deb11u3fixed
bookworm (security), bookworm5.7-2+deb12u1fixed
sid, trixie6.10-1fixed
squid3 (PTS)jessie, jessie (lts)3.5.23-5+deb8u7fixed
stretch (security)3.5.23-5+deb9u7fixed
stretch (lts), stretch3.5.23-5+deb9u10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsourcebuster(not affected)
squidsourcebullseye(not affected)
squidsourcebookworm5.7-2+deb12u1
squidsource(unstable)6.5-11055251
squid3source(unstable)(not affected)

Notes

[bullseye] - squid <not-affected> (Vulnerable code not present)
[buster] - squid <not-affected> (Vulnerable code not present)
- squid3 <not-affected> (Vulnerable code not present)
https://github.com/squid-cache/squid/security/advisories/GHSA-2g3c-pg7q-g59w

Search for package or bug name: Reporting problems