CVE-2023-50009

NameCVE-2023-50009
DescriptionBuffer Overflow vulnerability in Ffmpeg v.n6.1-3-g466799d4f5 allows a local attacker to execute arbitrary code via the ff_gaussian_blur_8 function in libavfilter/edge_template.c:116:5 component.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch (security)7:3.2.18-0+deb9u1fixed
stretch (lts), stretch7:3.2.19-0+deb9u4fixed
buster7:4.1.9-0+deb10u1vulnerable
buster (security)7:4.1.11-0+deb10u1vulnerable
bullseye7:4.3.6-0+deb11u1vulnerable
bullseye (security)7:4.3.7-0+deb11u1vulnerable
bookworm (security), bookworm7:5.1.5-0+deb12u1vulnerable
trixie7:6.1.1-4vulnerable
sid7:6.1.1-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourceexperimental7:7.0-1
ffmpegsourcestretch(not affected)
ffmpegsource(unstable)(unfixed)

Notes

[bookworm] - ffmpeg <postponed> (Pick up when fixed in 5.1.x)
[bullseye] - ffmpeg <postponed> (Pick up when fixed in 4.3.x)
[buster] - ffmpeg <postponed> (Pick up when fixed in most related branch)
https://github.com/FFmpeg/FFmpeg/commit/c443658d26d2b8e19901f9507a890e0efca79056 (n7.0)
https://trac.ffmpeg.org/ticket/10699
[stretch] - ffmpeg <not-affected> (The vulnerable code was introduced later)

Search for package or bug name: Reporting problems