CVE-2023-50010

NameCVE-2023-50010
DescriptionBuffer Overflow vulnerability in Ffmpeg v.n6.1-3-g466799d4f5 allows a local attacker to execute arbitrary code via the set_encoder_id function in /fftools/ffmpeg_enc.c component.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-5712-1, DSA-5721-1, ELA-1125-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch (security)7:3.2.18-0+deb9u1vulnerable
stretch (lts), stretch7:3.2.19-0+deb9u4fixed
buster7:4.1.9-0+deb10u1vulnerable
buster (security)7:4.1.11-0+deb10u1vulnerable
bullseye7:4.3.6-0+deb11u1vulnerable
bullseye (security)7:4.3.7-0+deb11u1fixed
bookworm (security), bookworm7:5.1.5-0+deb12u1fixed
trixie7:6.1.1-4vulnerable
sid7:6.1.1-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsourceexperimental7:7.0-1
ffmpegsourcestretch7:3.2.19-0+deb9u4ELA-1125-1
ffmpegsourcebullseye7:4.3.7-0+deb11u1DSA-5721-1
ffmpegsourcebookworm7:5.1.5-0+deb12u1DSA-5712-1
ffmpegsource(unstable)(unfixed)

Notes

[buster] - ffmpeg <postponed> (Pick up when fixed in most related branch)
https://trac.ffmpeg.org/ticket/10702
https://github.com/FFmpeg/FFmpeg/commit/e4d2666bdc3dbd177a81bbf428654a5f2fa3787a (n7.0)

Search for package or bug name: Reporting problems