CVE-2023-5824

NameCVE-2023-5824
DescriptionSquid is vulnerable to Denial of Service attack against HTTP and HTTPS clients due to an Improper Handling of Structural Elements bug.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1055249

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)buster4.6-1+deb10u7vulnerable
buster (security)4.6-1+deb10u10vulnerable
bullseye (security), bullseye4.13-10+deb11u2vulnerable
bookworm5.7-2vulnerable
sid, trixie6.6-1fixed
squid3 (PTS)jessie, jessie (lts)3.5.23-5+deb8u7vulnerable
stretch (security)3.5.23-5+deb9u7vulnerable
stretch (lts), stretch3.5.23-5+deb9u10vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)6.5-11055249
squid3source(unstable)(unfixed)

Notes

https://github.com/squid-cache/squid/security/advisories/GHSA-543m-w2m2-g255

Search for package or bug name: Reporting problems