CVE-2024-24826

NameCVE-2024-24826
DescriptionExiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 version v0.28.1. The vulnerable function, `QuickTimeVideo::NikonTagsDecoder`, was new in v0.28.0, so Exiv2 versions before v0.28 are _not_ affected. The out-of-bounds read is triggered when Exiv2 is used to read the metadata of a crafted video file. In most cases this out of bounds read will result in a crash. This bug is fixed in version v0.28.2. Users are advised to upgrade. There are no known workarounds for this vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs1070392

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exiv2 (PTS)jessie, jessie (lts)0.24-4.1+deb8u7vulnerable
stretch (security)0.25-3.1+deb9u3vulnerable
stretch (lts), stretch0.25-3.1+deb9u4vulnerable
buster0.25-4+deb10u2vulnerable
buster (security)0.25-4+deb10u4vulnerable
bullseye0.27.3-3+deb11u2vulnerable
bullseye (security)0.27.3-3+deb11u1vulnerable
sid, trixie, bookworm0.27.6-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exiv2sourceexperimental0.28.2+dfsg-1
exiv2source(unstable)(unfixed)1070392

Notes

[bookworm] - exiv2 <no-dsa> (Minor issue)
[bullseye] - exiv2 <no-dsa> (Minor issue)
[buster] - exiv2 <no-dsa> (Minor issue)
https://github.com/Exiv2/exiv2/security/advisories/GHSA-g9xm-7538-mq8w
https://github.com/Exiv2/exiv2/pull/2337
GHSA mentions new in v0.28.0, but that only applies to the "main" branch, where
it was removed and later reintroduced. The 0.27-maintenance branch _does_ include
the Quicktime decoder
[stretch] - exiv2 <ignored> (Minor issue)
[jessie] - exiv2 <ignored> (Minor issue)

Search for package or bug name: Reporting problems