Information on source package php8.2

Available versions

ReleaseVersion
bookworm8.2.7-1~deb12u1
bookworm (security)8.2.20-1~deb12u1
trixie8.2.18-1
sid8.2.20-2

Open issues

BugbookwormtrixiesidDescription
CVE-2024-5458fixedvulnerablefixedIn PHP versions8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before ...
CVE-2024-2408vulnerable (no DSA, postponed)vulnerablevulnerableThe openssl_private_decrypt function in PHP, when using PKCS1 padding ...

Resolved issues

BugDescription
CVE-2024-5585In PHP versions8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before ...
CVE-2024-4577In PHP versions8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before ...
CVE-2024-3096In PHP version 8.1.* before 8.1.28, 8.2.* before 8.2.18, 8.3.* before ...
CVE-2024-2757In PHP 8.3.* before 8.3.5, functionmb_encode_mimeheader() runs endless ...
CVE-2024-2756Due to an incomplete fix to CVE-2022-31629 https://github.com/advisor ...
CVE-2024-1874In PHP versions 8.1.* before 8.1.28, 8.2.* before 8.2.18, 8.3.* before ...
CVE-2023-3824In PHP version 8.0.* before 8.0.30, 8.1.* before 8.1.22, and 8.2.* bef ...
CVE-2023-3823In PHP versions 8.0.* before 8.0.30, 8.1.* before 8.1.22, and 8.2.* be ...
CVE-2023-3247In PHP versions 8.0.* before 8.0.29, 8.1.* before 8.1.20, 8.2.* before ...
CVE-2023-0662In PHP 8.0.X before 8.0.28, 8.1.X before 8.1.16 and 8.2.X before 8.2.3 ...
CVE-2023-0568In PHP 8.0.X before 8.0.28, 8.1.X before 8.1.16 and 8.2.X before 8.2.3 ...
CVE-2023-0567In PHP 8.0.X before 8.0.28, 8.1.X before 8.1.16 and 8.2.X before 8.2.3 ...
CVE-2022-31631
CVE-2022-4900A vulnerability was found in PHP where setting the environment variabl ...

Security announcements

DSA / DLADescription
DSA-5717-1php8.2 - security update
DSA-5661-1php8.2 - security update
DSA-5425-1php8.2 - security update

Search for package or bug name: Reporting problems