ELA-124-1 tomcat7 security update

XSS in SSI printenv

2019-05-31
Packagetomcat7
Version7.0.28-4+deb7u21
Related CVE CVE-2019-0221

It was discovered that the SSI printenv command echoes user provided data without escaping and is, therefore, vulnerable to XSS. SSI is disabled by default. The printenv command is intended for debugging and is unlikely to be present in a production website.

For Debian 7 Wheezy, these problems have been fixed in version 7.0.28-4+deb7u21.

We recommend that you upgrade your tomcat7 packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/