ELA-132-1 bzip2 security update

fix for out-of-bounds write and use-after-free

2019-06-22
Packagebzip2
Version1.0.6-4+deb7u1
Related CVE CVE-2016-3189 CVE-2019-12900

Two issues in bzip2, a high-quality block-sorting file compressor, have been fixed. One, CVE-2019-12900, is a out-of-bounds write when using a crafted compressed file. The other, CVE-2016-3189, is a potential user-after-free.

For Debian 7 Wheezy, these problems have been fixed in version 1.0.6-4+deb7u1.

We recommend that you upgrade your bzip2 packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/