ELA-206-1 apache-log4j1.2 security update

remote code execution

2020-01-11
Packageapache-log4j1.2
Version1.2.16-3+deb7u1
Related CVE CVE-2019-17571

Included in Log4j 1.2, a logging library for Java, is a SocketServer class that is vulnerable to deserialization of untrusted data which can be exploited to remotely execute arbitrary code when combined with a deserialization gadget when listening to untrusted network traffic for log data.

For Debian 7 Wheezy, these problems have been fixed in version 1.2.16-3+deb7u1.

We recommend that you upgrade your apache-log4j1.2 packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/