ELA-220-1 php5 security update

fix for null pointer dereference and lax access permissions in tar file

2020-03-27
Packagephp5
Version5.4.45-0+deb7u28
Related CVE CVE-2020-7062 CVE-2020-7063

Two security issues have been identified and fixed in php5, a server-side, HTML-embedded scripting language.

CVE-2020-7062 is about a possible null pointer derefernce, which would likely lead to a crash, during a failed upload with progress tracking. CVE-2020-7063 is about wrong file permissions of files added to tar with Phar::buildFromIterator when extracting them again.

For Debian 7 Wheezy, these problems have been fixed in version 5.4.45-0+deb7u28.

We recommend that you upgrade your php5 packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/