ELA-279-1 imagemagick security update

buffer overflow

2020-09-05
Packageimagemagick
Version8:6.8.9.9-5+deb8u21
Related CVEs CVE-2017-12806 CVE-2019-13308 CVE-2019-13391

Several security vulnerabilities have been addressed in imagemagick, an image processing toolkit.

CVE-2017-12806

A memory exhaustion vulnerability was found in the function format8BIM, which allows
attackers to cause a denial of service.

CVE-2019-13308, CVE-2019-13391

Heap-based buffer overflow in MagickCore/fourier.c in ComplexImages may
cause a denial-of-service or other unspecified results.

For Debian 8 jessie, these problems have been fixed in version 8:6.8.9.9-5+deb8u21.

We recommend that you upgrade your imagemagick packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/