ELA-28-1 tomcat-native security update

authentication bypass

Packagetomcat-native
Version1.1.24-1+deb7u2
Related CVE CVE-2018-8019 CVE-2018-8020

When using an OCSP responder Tomcat Native did not correctly handle invalid responses. This allowed for revoked client certificates to be incorrectly identified. It was therefore possible for users to authenticate with revoked certificates when using mutual TLS. Users not using OCSP checks are not affected by this vulnerability.

For Debian 7 Wheezy, these problems have been fixed in version 1.1.24-1+deb7u2.

We recommend that you upgrade your tomcat-native packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/