ELA-281-1 python-pip security update

directory traversal vulnerability

2020-09-11
Packagepython-pip
Version1.5.6-5+deb8u1
Related CVEs CVE-2019-20916

It was discovered that there was a directory traversal attack in pip, the Python package installer.

When an URL was given in an install command, as a Content-Disposition HTTP header was permitted to have ../ components in its filename, arbitrary local files (eg. /root/.ssh/authorized_keys) could be overidden.

For Debian 8 Jessie, these problems have been fixed in version 1.5.6-5+deb8u1.

We recommend that you upgrade your python-pip packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/