ELA-297-1 packagekit security update

multiple vulnerabilities

2020-10-11
Packagepackagekit
Version1.0.1-2+deb8u1
Related CVEs CVE-2020-16121 CVE-2020-16122

Two vulnerabilities have been discovered in packagekit, a package management service.

CVE-2020-16121

Vaisha Bernard discovered that PackageKit incorrectly handled
certain methods. A local attacker could use this issue to learn the
MIME type of any file on the system.

CVE-2020-16122

Sami Niemimäki discovered that PackageKit incorrectly handled local
deb packages. A local user could possibly use this issue to install
untrusted packages, contrary to expectations.

For Debian 8 jessie, these problems have been fixed in version 1.0.1-2+deb8u1.

We recommend that you upgrade your packagekit packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/