ELA-347-1 ruby-redcarpet security update

cross-site scripting

2021-01-16
Packageruby-redcarpet
Version3.1.2-1+deb8u1
Related CVEs CVE-2020-26298

In Redcarpet before version 3.5.1, there is an injection vulnerability which can enable a cross-site scripting attack.

In affected versions, no HTML escaping was being performed when processing quotes. This applies even when the :escape_html option was being used.

For Debian 8 jessie, these problems have been fixed in version 3.1.2-1+deb8u1.

We recommend that you upgrade your ruby-redcarpet packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/