ELA-45-1 dom4j security update

XML Injection vulnerability

Packagedom4j
Version1.6.1+dfsg.3-2+deb7u1
Related CVE CVE-2018-1000632

Mario Areias discovered that dom4j, a XML framework for Java, was vulnerable to a XML injection attack. An attacker able to specify attributes or elements in the XML document might be able to modify the whole XML document.

This update also removes non-free files from the source package and the dependency on backport-util-concurrent. It requires the new dependency libmsv-java though.

For Debian 7 Wheezy, these problems have been fixed in version 1.6.1+dfsg.3-2+deb7u1.

We recommend that you upgrade your dom4j packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/