ELA-468-1 libkohana2-php security update

cross-site scripting (XSS) attack

2021-08-04
Packagelibkohana2-php
Version2.3.4-2+deb8u1
Related CVEs CVE-2016-10510

David Sopas discovered that Kohana, a PHP framework, was vulnerable to a Cross-site scripting (XSS) attack that allowed remote attackers to inject arbitrary web script or HTML by bypassing the strip_image_tags protection mechanism in system/classes/Kohana/Security.php. This issue was resolved by permanently removing the strip_image_tags function. Users are advised to sanitize user input by using external libraries instead.

For Debian 8 jessie, these problems have been fixed in version 2.3.4-2+deb8u1.

We recommend that you upgrade your libkohana2-php packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/