ELA-477-1 libspf2 security update

stack buffer overflow

2021-08-11
Packagelibspf2
Version1.2.10-5+deb8u1
Related CVEs CVE-2021-20314

Philipp Jeitner and Haya Shulman discovered a stack-based buffer overflow in libspf2, a library for validating mail senders with SPF, which could result in denial of service, or potentially execution of arbitrary code when processing a specially crafted SPF record.

For Debian 8 jessie, these problems have been fixed in version 1.2.10-5+deb8u1.

We recommend that you upgrade your libspf2 packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/