ELA-602-1 tinyxml security update

infinite loop

2022-04-30
Packagetinyxml
Version2.6.2-2+deb8u1
Related CVEs CVE-2021-42260

An issue has been found in tinyxml, a C++ XML parsing library. Crafted XML messages could lead to an infinite loop in TiXmlParsingData::Stamp(), which results in a denial of service.

For Debian 8 jessie, these problems have been fixed in version 2.6.2-2+deb8u1.

We recommend that you upgrade your tinyxml packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/