ELA-651-1 gsasl security update

out-of-bounds read vulnerability

2022-07-23
Packagegsasl
Version1.8.0-6+deb8u1 (jessie), 1.8.0-8+deb9u1 (stretch)
Related CVEs CVE-2022-2469

Prevent a potential read-out-of-bounds vulnerability was discovered in gsasl, a library for performing SASL authentication. The attack could have been performed by a malicious (authenticated) GSS-API client.

For Debian 8 jessie, these problems have been fixed in version 1.8.0-6+deb8u1.

For Debian 9 stretch, these problems have been fixed in version 1.8.0-8+deb9u1.

We recommend that you upgrade your gsasl packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/