ELA-654-1 xorg-server security update

out of bounds write

2022-07-26
Packagexorg-server
Version2:1.16.4-1+deb8u7 (jessie), 2:1.19.2-1+deb9u10 (stretch)
Related CVEs CVE-2022-2319 CVE-2022-2320

Jan-Niklas Sohn discovered two out of bound memory writes in X.Org Server’s ProcXkbSetGeometry and ProcXkbSetDeviceInfo Xkb extensions. These issues could be exploited by an attacker to cause denial of service, privilege escalation or arbitrary code execution.

For Debian 8 jessie, these problems have been fixed in version 2:1.16.4-1+deb8u7.

For Debian 9 stretch, these problems have been fixed in version 2:1.19.2-1+deb9u10.

We recommend that you upgrade your xorg-server packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/