ELA-655-1 libhttp-daemon-perl security update

bad Content-Length: handling

2022-08-01
Packagelibhttp-daemon-perl
Version6.01-1+deb8u1 (jessie), 6.01-1+deb9u1 (stretch)
Related CVEs CVE-2022-31081

An issue has been found in libhttp-daemon-perl, a simple http server class. Due to insufficient Content-Length: handling in HTTP-header an attacker could gain privileged access to APIs or poison intermediate caches.

For Debian 8 jessie, these problems have been fixed in version 6.01-1+deb8u1.

For Debian 9 stretch, these problems have been fixed in version 6.01-1+deb9u1.

We recommend that you upgrade your libhttp-daemon-perl packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/