ELA-677-1 zlib security update

heap buffer overflow

2022-09-12
Packagezlib
Version1:1.2.8.dfsg-2+deb8u3 (jessie), 1:1.2.8.dfsg-5+deb9u2 (stretch)
Related CVEs CVE-2022-37434

Evgeny Legerov reported a heap-based buffer overflow vulnerability in the inflate operation in zlib, which could result in denial of service or potentially the execution of arbitrary code if specially crafted input is processed.

For Debian 8 jessie, these problems have been fixed in version 1:1.2.8.dfsg-2+deb8u3.

For Debian 9 stretch, these problems have been fixed in version 1:1.2.8.dfsg-5+deb9u2.

We recommend that you upgrade your zlib packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/