ELA-68-1 libapache-mod-jk security update

information disclosure and privilege escalation

2018-12-17
Packagelibapache-mod-jk
Version1.2.46-0+deb7u1
Related CVE CVE-2018-11759

A vulnerability has been discovered in libapache-mod-jk, the Apache 2 connector for the Tomcat Java servlet engine.

The libapache-mod-jk connector is susceptible to information disclosure and privilege escalation because of a mishandling of URL normalization.

The nature of the fix required that libapache-mod-jk in Debian 7 “Wheezy” be updated to the latest upstream release. For reference, the upstream changes associated with each release version are documented here:

http://tomcat.apache.org/connectors-doc/miscellaneous/changelog.html

For Debian 7 Wheezy, these problems have been fixed in version 1.2.46-0+deb7u1.

We recommend that you upgrade your libapache-mod-jk packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/