CVE-2014-0193

NameCVE-2014-0193
DescriptionWebSocket08FrameDecoder in Netty 3.6.x before 3.6.9, 3.7.x before 3.7. ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2110-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netty (PTS)jessie, jessie (lts)1:3.2.6.Final-2+deb8u2fixed
stretch1:4.1.7-2+deb9u1fixed
stretch (security)1:4.1.7-2+deb9u3fixed
buster (security), buster1:4.1.33-1+deb10u2fixed
sid, bookworm, bullseye1:4.1.48-4fixed
netty-3.9 (PTS)jessie, jessie (lts)3.9.0.Final-1+deb8u1fixed
stretch3.9.9.Final-1fixed
stretch (security)3.9.9.Final-1+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nettysource(unstable)(not affected)
netty-3.9sourcejessie3.9.0.Final-1+deb8u1DLA-2110-1
netty-3.9source(unstable)3.9.9.Final-1

Notes

- netty <not-affected> (WebSocket08FrameDecoder function not present; bug #746639)
https://github.com/netty/netty/commit/48edb7802b42b0e2eb5a55d8eca390e0c9066783

Search for package or bug name: Reporting problems