CVE-2021-3426

NameCVE-2021-3426
DescriptionThere's a flaw in Python 3's pydoc. A local or adjacent attacker who discovers or is able to convince another local or adjacent user to start a pydoc server could access the server and use it to disclose sensitive information belonging to the other user that they would not normally be able to access. The highest risk of this flaw is to data confidentiality. This flaw affects Python versions before 3.8.9, Python versions before 3.9.3 and Python versions before 3.10.0a7.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2619-1, DLA-3477-1, ELA-510-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pypy3 (PTS)buster7.0.0+dfsg-3vulnerable
bullseye (security), bullseye7.3.5+dfsg-2+deb11u2fixed
bookworm7.3.11+dfsg-2+deb12u1fixed
sid, trixie7.3.15+dfsg-1fixed
python2.7 (PTS)jessie, jessie (lts)2.7.9-2-ds1-1+deb8u11fixed
stretch (security)2.7.13-2+deb9u6fixed
stretch (lts), stretch2.7.13-2+deb9u8fixed
buster2.7.16-2+deb10u1fixed
buster (security)2.7.16-2+deb10u3fixed
bullseye2.7.18-8+deb11u1fixed
python3.4 (PTS)jessie, jessie (lts)3.4.2-1+deb8u15fixed
python3.5 (PTS)stretch (security)3.5.3-1+deb9u5fixed
stretch (lts), stretch3.5.3-1+deb9u8fixed
python3.7 (PTS)buster3.7.3-2+deb10u3vulnerable
buster (security)3.7.3-2+deb10u6fixed
python3.9 (PTS)bullseye3.9.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pypy3source(unstable)7.3.3+dfsg-4
python2.7source(unstable)(not affected)
python3.4sourcejessie3.4.2-1+deb8u11ELA-510-1
python3.4source(unstable)(unfixed)
python3.5sourcestretch3.5.3-1+deb9u4DLA-2619-1
python3.5source(unstable)(unfixed)
python3.7sourcebuster3.7.3-2+deb10u5DLA-3477-1
python3.7source(unstable)(unfixed)
python3.9sourceexperimental3.9.3-1
python3.9source(unstable)3.9.7-1

Notes

[bullseye] - python3.9 <no-dsa> (Minor issue)
- python2.7 <not-affected> (Vulnerable code not present)
[buster] - pypy3 <no-dsa> (Minor issue)
https://bugs.python.org/issue42988
https://github.com/python/cpython/commit/9b999479c0022edfc9835a8a1f06e046f3881048
https://python-security.readthedocs.io/vuln/pydoc-getfile.html
https://github.com/python/cpython/pull/24337
https://github.com/python/cpython/pull/24285
[jessie] - python3.4 <no-dsa> (Minor issue, getfile-feature of pydoc seldom used)

Search for package or bug name: Reporting problems