Information on source package python3.9

Available versions

ReleaseVersion
bullseye3.9.2-1

Open issues

BugbullseyeDescription
CVE-2022-45061vulnerable (no DSA)An issue was discovered in Python before 3.11.1. An unnecessary quadra ...
CVE-2022-42919vulnerable (no DSA)Python 3.9.x before 3.9.16 and 3.10.x before 3.10.9 on Linux allows lo ...
CVE-2022-0391vulnerable (no DSA)A flaw was found in Python, specifically within the urllib.parse modul ...
CVE-2021-29921vulnerable (no DSA)In Python before 3,9,5, the ipaddress library mishandles leading zero ...
CVE-2021-4189vulnerable (no DSA)A flaw was found in Python, specifically in the FTP (File Transfer Pro ...
CVE-2021-3737vulnerable (no DSA)A flaw was found in python. An improperly handled HTTP response in the ...
CVE-2021-3733vulnerable (no DSA)There's a flaw in urllib's AbstractBasicAuthHandler class. An attacker ...
CVE-2021-3426vulnerable (no DSA)There's a flaw in Python 3's pydoc. A local or adjacent attacker who d ...
CVE-2020-10735vulnerable (no DSA)A flaw was found in python. In algorithms with quadratic time complexi ...
CVE-2015-20107vulnerable (no DSA)In Python (aka CPython) up to 3.10.8, the mailcap module does not add ...

Open unimportant issues

BugbullseyeDescription
CVE-2022-37454vulnerableThe Keccak XKCP SHA-3 reference implementation before fdc6fef has an i ...
CVE-2021-28861vulnerable** DISPUTED ** Python 3.x through 3.10 has an open redirection vulnera ...
CVE-2020-27619vulnerableIn Python 3 through 3.9.0, the Lib/test/multibytecodec_support.py CJK ...

Resolved issues

BugDescription
CVE-2022-26488In Python before 3.10.3 on Windows, local users can gain privileges be ...
CVE-2021-23336The package python/cpython from 0 and before 3.6.13, from 3.7.0 and be ...
CVE-2021-3177Python 3.x through 3.9.1 has a buffer overflow in PyCArg_repr in _ctyp ...
CVE-2020-26116http.client in Python 3.x before 3.5.10, 3.6.x before 3.6.12, 3.7.x be ...
CVE-2020-15801In Python 3.8.4, sys.path restrictions specified in a python38._pth fi ...
CVE-2019-20907In Lib/tarfile.py in Python through 3.8.3, an attacker is able to craf ...

Search for package or bug name: Reporting problems