CVE-2023-24329

NameCVE-2023-24329
DescriptionAn issue in the urllib.parse component of Python before 3.11.4 allows attackers to bypass blocklisting methods by supplying a URL that starts with blank characters.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3575-1, ELA-950-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python2.7 (PTS)jessie, jessie (lts)2.7.9-2-ds1-1+deb8u11fixed
stretch (security)2.7.13-2+deb9u6vulnerable
stretch (lts), stretch2.7.13-2+deb9u8fixed
buster2.7.16-2+deb10u1vulnerable
buster (security)2.7.16-2+deb10u3fixed
bullseye2.7.18-8+deb11u1fixed
python3.11 (PTS)bookworm3.11.2-6vulnerable
trixie3.11.8-1fixed
sid3.11.8-3fixed
python3.4 (PTS)jessie, jessie (lts)3.4.2-1+deb8u15vulnerable
python3.5 (PTS)stretch (security)3.5.3-1+deb9u5vulnerable
stretch (lts), stretch3.5.3-1+deb9u8vulnerable
python3.7 (PTS)buster3.7.3-2+deb10u3vulnerable
buster (security)3.7.3-2+deb10u6vulnerable
python3.9 (PTS)bullseye3.9.2-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python2.7sourcejessie2.7.9-2-ds1-1+deb8u11ELA-950-1
python2.7sourcestretch2.7.13-2+deb9u8ELA-950-1
python2.7sourcebuster2.7.16-2+deb10u3DLA-3575-1
python2.7sourcebullseye2.7.18-8+deb11u1
python2.7source(unstable)(unfixed)
python3.11source(unstable)3.11.4-1
python3.4source(unstable)(unfixed)
python3.5source(unstable)(unfixed)
python3.7source(unstable)(unfixed)
python3.9source(unstable)(unfixed)

Notes

[bookworm] - python3.11 <no-dsa> (Minor issue)
[bullseye] - python3.9 <no-dsa> (Minor issue)
[buster] - python3.7 <ignored> (Cf. related CVE-2022-0391)
https://pointernull.com/security/python-url-parse-problem.html
https://github.com/python/cpython/pull/99421
https://github.com/python/cpython/pull/99446 (backport for 3.11 branch)
https://github.com/python/cpython/commit/439b9cfaf43080e91c4ad69f312f21fa098befc7 (v3.12.0a2)
https://github.com/python/cpython/commit/72d356e3584ebfb8e813a8e9f2cd3dccf233c0d9 (v3.11.1)
The change linked above does not seem to fix the CVE:
https://github.com/python/cpython/issues/102153
https://github.com/python/cpython/pull/104575 (3.11)
https://github.com/python/cpython/pull/104592 (3.11, 3.10)
https://github.com/python/cpython/pull/104593 (3.9)
https://github.com/python/cpython/commit/2f630e1ce18ad2e07428296532a68b11dc66ad10 (v3.12.0b1)
https://github.com/python/cpython/commit/610cc0ab1b760b2abaac92bd256b96191c46b941 (v3.11.4)
https://github.com/python/cpython/commit/f48a96a28012d28ae37a2f4587a780a5eb779946 (v3.10.12)
https://github.com/python/cpython/commit/d7f8a5fe07b0ff3a419ccec434cc405b21a5a304 (v3.9.17)
[jessie] - python3.4 <ignored> (Cf. related CVE-2022-0391)
[stretch] - python3.5 <ignored> (Cf. related CVE-2022-0391)

Search for package or bug name: Reporting problems