CVE-2021-3653

NameCVE-2021-3653
DescriptionA flaw was found in the KVM's AMD code for supporting SVM nested virtualization. The flaw occurs when processing the VMCB (virtual machine control block) provided by the L1 guest to spawn/handle a nested guest (L2). Due to improper validation of the "int_ctl" field, this issue could allow a malicious L1 to enable AVIC support (Advanced Virtual Interrupt Controller) for the L2 guest. As a result, the L2 guest would be allowed to read/write physical pages of the host, resulting in a crash of the entire system, leak of sensitive data or potential guest-to-host escape. This flaw affects Linux kernel versions prior to 5.14-rc7.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2785-1, DLA-2843-1, DSA-4978-1, ELA-535-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch (security), stretch (lts), stretch4.9.320-2fixed
buster4.19.235-1fixed
buster (security)4.19.249-2fixed
bullseye5.10.127-1fixed
bullseye (security)5.10.127-2fixed
bookworm5.18.14-1fixed
sid5.18.16-1fixed
linux-4.19 (PTS)stretch (security)4.19.232-1~deb9u1fixed
stretch (lts), stretch4.19.249-2~deb9u1fixed
linux-4.9 (PTS)jessie, jessie (lts)4.9.303-1~deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch4.9.290-1DLA-2843-1
linuxsourcebuster4.19.208-1
linuxsourcebullseye5.10.46-5DSA-4978-1
linuxsource(unstable)5.14.6-1
linux-4.19sourcestretch4.19.208-1~deb9u1DLA-2785-1
linux-4.9sourcejessie4.9.290-1~deb8u1ELA-535-1

Notes

https://www.openwall.com/lists/oss-security/2021/08/16/1

Search for package or bug name: Reporting problems