CVE-2021-38160

NameCVE-2021-38160
Description** DISPUTED ** In drivers/char/virtio_console.c in the Linux kernel before 5.13.4, data corruption or loss can be triggered by an untrusted device that supplies a buf->len value exceeding the buffer size. NOTE: the vendor indicates that the cited data corruption is not a vulnerability in any existing use case; the length validation was added solely for robustness in the face of anomalous host OS behavior.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2785-1, DLA-2843-1, DSA-4978-1, ELA-535-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch (security), stretch (lts), stretch4.9.320-2fixed
buster4.19.235-1fixed
buster (security)4.19.249-2fixed
bullseye5.10.127-1fixed
bullseye (security)5.10.127-2fixed
bookworm5.18.14-1fixed
sid5.18.16-1fixed
linux-4.19 (PTS)stretch (security)4.19.232-1~deb9u1fixed
stretch (lts), stretch4.19.249-2~deb9u1fixed
linux-4.9 (PTS)jessie, jessie (lts)4.9.303-1~deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch4.9.290-1DLA-2843-1
linuxsourcebuster4.19.208-1
linuxsourcebullseye5.10.46-5DSA-4978-1
linuxsource(unstable)5.14.6-1
linux-4.19sourcestretch4.19.208-1~deb9u1DLA-2785-1
linux-4.9sourcejessie4.9.290-1~deb8u1ELA-535-1

Notes

https://git.kernel.org/linus/d00d8da5869a2608e97cfede094dfc5e11462a46

Search for package or bug name: Reporting problems