CVE-2021-38511

NameCVE-2021-38511
DescriptionAn issue was discovered in the tar crate before 0.4.36 for Rust. When ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs992173

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rust-tar (PTS)buster0.4.20-1vulnerable
bookworm, sid, bullseye0.4.26-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rust-tarsource(unstable)(unfixed)992173

Notes

[bullseye] - rust-tar <no-dsa> (Minor issue)
[buster] - rust-tar <no-dsa> (Minor issue)
https://rustsec.org/advisories/RUSTSEC-2021-0080.html
https://github.com/alexcrichton/tar-rs/issues/238

Search for package or bug name: Reporting problems