CVE-2021-42008

NameCVE-2021-42008
DescriptionThe decode_data function in drivers/net/hamradio/6pack.c in the Linux kernel before 5.13.13 has a slab out-of-bounds write. Input from a process that has the CAP_NET_ADMIN capability can lead to root access.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2785-1, DLA-2843-1, ELA-535-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)jessie, jessie (lts)3.16.84-1vulnerable
stretch4.9.228-1vulnerable
stretch (security)4.9.290-1fixed
buster4.19.208-1fixed
buster (security)4.19.194-3vulnerable
bullseye5.10.84-1fixed
bullseye (security)5.10.46-5vulnerable
sid, bookworm5.15.5-2fixed
linux-4.19 (PTS)stretch (security)4.19.208-1~deb9u1fixed
linux-4.9 (PTS)jessie, jessie (lts)4.9.290-1~deb8u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcejessie(unfixed)end-of-life
linuxsourcestretch4.9.290-1DLA-2843-1
linuxsourcebuster4.19.208-1
linuxsourcebullseye5.10.70-1
linuxsource(unstable)5.14.6-1
linux-4.19sourcestretch4.19.208-1~deb9u1DLA-2785-1
linux-4.9sourcejessie4.9.290-1~deb8u1ELA-535-1

Notes

https://git.kernel.org/linus/19d1532a187669ce86d5a2696eb7275310070793 (5.14-rc7)

Search for package or bug name: Reporting problems