ELA-313-1 zeromq3 security update

DOS on CURVE/ZAP-protected servers

2020-11-10
Packagezeromq3
Version4.0.5+dfsg-2+deb8u3
Related CVEs CVE-2020-15166

It was discovered that ZeroMQ, a lightweight messaging kernel library does not properly handle connecting peers before a handshake is completed. A remote, unauthenticated client connecting to an application using the libzmq library, running with a socket listening with CURVE encryption/authentication enabled can take advantage of this flaw to cause a denial of service affecting authenticated and encrypted clients.

For Debian 8 jessie, these problems have been fixed in version 4.0.5+dfsg-2+deb8u3.

We recommend that you upgrade your zeromq3 packages.

Further information about Extended LTS security advisories can be found at: https://deb.freexian.com/extended-lts/